Microsoft-HTTPAPI/2.0 No deja iniciar Servidor Apache – Solución

Servidor apache no inicia

Me he topado con este problema al iniciar el servidor Apache. No es posible iniciarlo pues hay otro programa escuchando el puerto 80. Al ver el puerto 80 desde la utilidad de apache, nos dice que el servicio Microsoft-HTTPAPI/2.0 está ocupando el puerto, y por lo tanto no se inicia.

He encontrado varias soluciones para este problema, y aunque no se hable especificamente del: Microsoft-HTTPAPI/2.0 esto mismo te puede servir para solucionar cualquier inconveniente a la hora de iniciar el servidor apache.

posibles soluciones:

1 – Cambiar el puerto del servidor apache: Veremos como configurar el puerto del servidor apache de tal manera que no haya problemas con otros programas que usen el mismo puerto.

2 – Quitar los otros servicios: Veremos como deshabilitar los servicios que evitan que el servidor apache funcione correctamente.

 

Continuar leyendo…

1 – Cambiar el puerto del servidor apache:

Si estás usando WAMPSERVER puedes abrir el archivo httpd.conf dando clic al icono de WAMPSERVER y navegando por el menu hasta la opcion de apache, y dar clic en httpd.conf.

Nota: Si no usas WAMPSERVER puedes ir hasta la ruta de instalacion de Apache, y de ahí navegar a la carpeta: “conf”. Ejemplo:

C:\Archivos de programa\Apache 2.XX.XX\Conf\httpd.conf

Luego abrir el archivo httpd.conf con el bloc de notas.

Una vez que lo hayas abierto, busca la linea:

Listen 80

y cambia el Numero 80, por el numero de puerto que desees, puede ser 8080 o cualquier otro.

Despues de esto reinicia el servicio de Apache, y ahora ve al navegador, entra con:

Http://localhost:8080/

Recuerda que debes cambiar ese “8080” por el numero de puerto que tu escribiste.

2 – Quitar los otros servicios

Algunos servicios pueden estar usando el puerto 80, y por lo tanto el servidor Apache no puede iniciar. Para solucionar esto, ve a Inicio / Ejecutar o presionando WIN + R, se abrirá la ventanita de Ejecutar. Allí escribe: “Services.msc” para abrir el administrador de servicios de Windows.

En mi caso especifico detuve el servicio: “Servicio agente de implementacion Web”, si tu Windows está en inglés este servicio se llama: “Web Deployment Agent Service”.

Debes detener el servicio, y cambiar el tipo de inicio a “Manual”. Puedes hacerlo dando clic derecho sobre el, y luego “propiedades”, quedará algo como esto:

 

Otros servicios que te pueden causar conflictos son:

“SQL Server Reporting Services (MSSQLSERVER)” o en español: “Servicio de reporte de SQL Server” (o una traduccion similar)

 

Después de aplicar cualquiera de estas soluciones reinicia el servicio de Apache, y ya iniciará correctamente

Los medicamentos, absolutamente, van a cambiar tu vida. Si el problema persiste durante un perГ­odo mГЎs largo, se debe consultar a un mГ©dico. ВїTiene alguna cuestión sobre Kamagra y comprare cialis? Por supuesto que no es todo. ВїQuГ© medicamento es adecuado para la incapacidad para obtener o mantener una erecciГіn? Tal vez usted sabe sobre . Otra pregunta que tenemos que discutir es . Tener impotencia puede complicar el romance. Todo tipo de medicamentos, desde aquellos que se consideran “todos naturales” a los que se producen quГ­micamente en un laboratorio, pueden causar algunos efectos secundarios no deseados.

25 respuesta a “Microsoft-HTTPAPI/2.0 No deja iniciar Servidor Apache – Solución”

  1. De verdad muchas gracias!. En internet hay mucha información redundante que no muestran el verdadero núcleo de este problema. Tu solución simple y clara. Como dicen, el que sabe, sabe, y el que no inventa y deja puras *****…

      1. De vdeard muchas gracias!. En internet hay mucha información redundante que no muestran el vdeardero núcleo de este problema. Tu solución simple y clara. Como dicen, el que sabe, sabe, y el que no inventa y deja puras *****…

  2. En W7 hay que parar el IIS
    Panel de control> Sistema y seguridad> Herramientas administrativas>Administrador de Internet Information Services>Acciones Detener

    es lo mas práctico

  3. Que tal, les cuento que aparte de detener los servicios que se mencionan arriba, tambien detuve el servicio de BranchCache, con lo cual apache y por ende el Wammp funciono.
    Saludos

  4. Eres el puto amo :D:D:D:D:D:D:D:D:D:D no se cual es el programa que no me deja utilizar el puerto 80 pero he cambiado de puerto y ahora me funciona perfectamente!!!!!!!!!!!!!!!!!!!!!!!!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.